• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Blueberries, no flowers or fruit

 
Vlad Sklyar
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

In fall of 2011 I started mu blueberry garden: Duke, Jubilee, Biloxi, Jersey, and some other. All of them was 2-3 year old. In 2012 I got good harvest especial from 4 Dukes, Jubilee, and Biloxi. This year said bushes shown me ZERO! There was not even one flower. The rest (Blue ray, Chippewa, and Chandler are ok. What is wrong?

 
Rick Roman
pollinator
Posts: 442
Location: Pennsylvania Pocono Mt Neutral-Acidic Elv1024ft AYR41in Zone 5b
26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello Vlad and Welcome, I can try to help. Could you tell us your location?
 
janet jacobsen
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How's the ph?
 
Miles Flansburg
steward
Pie
Posts: 3549
Location: Zones 2-4 Wyoming and 4-5 Colorado
128
bee books forest garden fungi greening the desert hugelkultur
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Howdy Vlad, welcome to permies.
None of my fruit trees had blossoms this year, in Denver. We had a late warm up this spring and the trees didn't flower. How was your spring ?
 
Kelby Taylor
Posts: 47
Location: SE Pennsylvania, USA
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deer do enjoy blueberry buds, mine were snacked on a bit this past year.
 
janet jacobsen
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My blueberries did well the second year and less well the third. I had the soil tested, it was not acidic enough for blueberries to thrive. This spring I added sulphur flakes with some well composted soil. They are doing well again. You might want to get your soil tested.
 
Jeff McLeod
Posts: 95
Location: New Hampshire
2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
janet jacobsen wrote:My blueberries did well the second year and less well the third. I had the soil tested, it was not acidic enough for blueberries to thrive. This spring I added sulphur flakes with some well composted soil. They are doing well again. You might want to get your soil tested.


Totally agree. During the year we do some soil dressing with coffee grounds on a regular basis. And so far (touch wood) we've been getting increasingly good harvests.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic