• Post Reply Bookmark Topic Watch Topic
  • New Topic

Help with linux?  RSS feed

 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
2.5 years of bliss and today I get this.  Any suggestions?

Linux mint on a thinkpad w541.
Linux-is-sad.jpg
[Thumbnail for Linux-is-sad.jpg]
 
Adrien Lapointe
steward
Posts: 3430
Location: Kingston, Canada (USDA zone 5a)
206
chicken dog food preservation forest garden fungi tiny house toxin-ectomy trees woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you do a kernel update recently?
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adrien Lapointe wrote:Did you do a kernel update recently?


Nope.
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adrien Lapointe wrote:Did you do a kernel update recently?


I did some updates about a week ago.  I can't remember what all was in it.

 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Found this

https://forums.linuxmint.com/viewtopic.php?t=200214

It says that it has to do with my SD card reader.  Which I don't use.

I went to the bios stuff and couldn't find a way to turn it off.
 
Adrien Lapointe
steward
Posts: 3430
Location: Kingston, Canada (USDA zone 5a)
206
chicken dog food preservation forest garden fungi tiny house toxin-ectomy trees woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does the command line work? If so you can probably uninstall the driver
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Adrien Lapointe wrote:Does the command line work? If so you can probably uninstall the driver


I do have a very simple command line.

I have no idea what to type.  Suggestions?

 
leila hamaya
pollinator
Posts: 1143
Location: northern northern california
70
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i'd start with   - help

see what comes up from that in the command...

if it is sd card...maybe you want to  - unmount   - then whatever label it uses for sd card
? unsure...just a thought.
 
Tim Pasanen
Posts: 32
Location: Mediterranean-Temperate transition zone
8
cat chicken forest garden greening the desert hugelkultur solar trees woodworking
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
A bit of a long-shot Paul, but does this machine dual-boot, and did you previously boot into Windows?

Windows 10 (for example) has a 'Fast Start' option in (iirc) Control Panels > Power Options > System Setting > Currently Unavailable.  This can mess with the boot process.  As can anything that remotely sounds like 'hibernate' or 'suspend'.  I disabled all of that 'smart' garbage years ago, along with the pagefile, and haven't had problems since (except for Windows messing with my clock).

Long story short:  If you dual-boot into Windows, never, ever do anything but a full shutdown once you are finished, and disable as much energy/time-saving 'cleverness' as you can.

I avoid that hellish OS as much as I can.  Ubuntu 16.04 LTS has been rock-solid for me since I installed it.
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i almost forgot that i had a dual boot.   i went into it today (win7) when i could not get linux to work, and it was an ugly mess. 
 
Tim Pasanen
Posts: 32
Location: Mediterranean-Temperate transition zone
8
cat chicken forest garden greening the desert hugelkultur solar trees woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
paul wheaton wrote:i went into it today (win7) when i could not get linux to work, and it was an ugly mess. 

Please describe "ugly mess".  If it's just a disorderly desktop, that's one thing (that can be happily ignored), but if it looks like the graphics card is failing, that's a different one completely (and may point to a hardware fault).


So the last operating system that you booted into successfully — prior to the error message this morning — was Mint?
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I went into windows.  It was slow.  It is, I think, a fresh install of windows.  I was thinking that moment it connects to the internet, it will try to do a hundred upgrades including upgrading to win10.  So I shut it down quickly.
 
Tim Pasanen
Posts: 32
Location: Mediterranean-Temperate transition zone
8
cat chicken forest garden greening the desert hugelkultur solar trees woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
paul wheaton wrote:I went into windows.  It was slow.  It is, I think, a fresh install of windows.  I was thinking that moment it connects to the internet, it will try to do a hundred upgrades including upgrading to win10.  So I shut it down quickly.

Bingo.

The unclean/fast shutdown messed with your BIOS settings.  You need to perform at least one full and clean start-up and shut-down of Windows.  No suspends, no sleeps, no hibernates, no lid closing, no power-unplugging, no battery-low cut-outs.

1) Connect your laptop to AC so you're not running in battery/energy-saver mode.

2) If you don't want auto-downloads, disable WiFi on your laptop by pressing the appropriate button or, alternatively, turn off your router/WiFi hotspot.

3) Turn on your laptop and boot into Windows.

4) When it fails to connect to your WiFi network, all pending requests and (startup) scheduled update events will time out and fail.  Give it about 4 minutes to do so.

5) Then do a normal, full shut down.  Not a restart.  Not a sleep.  Not a hibernate.  A shut down.

6) Once off, leave it off for at least 8 seconds for capacitors to discharge.

7) Repeat steps 3-6.

8) Then turn your WiFi back on and boot into Mint.
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
To clarify. ...   Rather than seeing cinnamon, I see the same thing as what is in my first post.
 
Daniel Schmidt
Posts: 106
Location: Jacksonville, FL
9
solar tiny house woodworking
  • Likes 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not seeing why booting Windows would have anything to do with fixing Linux. He mentioned that he tried Windows after his Linux issue occurred, so that isn't the root problem.

A search is telling me that a bad superblock is aborting the boot process and causing it to fail which leaves you with the screen you posted above.

This AskUbuntu Page has some solutions. Doing a file system check using fsck should locate and correct the error. Apparently you can either do this from the command line or try running a live distro on USB or whatever works for you. I believe the first answer there shows a way of doing it which was required for an older Ubuntu version, as mentioned in the replies to the original question. Subsequent answers just refer to using fsck.

The real issue here is why it happened in the first place. It could have just been a fluke or a bug in one of the updates, or it could be an issue with the drive, particularly if it is a hard disk and not solid state. If it is a hard disk, once you get back into Mint, you can open the Disks utility and select the drive in the left pane, and on the right I believe under a tab for more options is something to the effect of SMART drive data. It gives all kinds of statistics on the drive and can warn you if it is in a pre-fail or imminent failure state.
 
leila hamaya
pollinator
Posts: 1143
Location: northern northern california
70
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
got curious enough to talk to google about this -->

https://bugzilla.redhat.com/show_bug.cgi?id=1289981

basically gathered that hitting Esc - escape - may allow the boot to proceed...

also if you want to blacklist the card reader - this may work

edit     /etc/modprobe.d/blacklist.conf
and insert the following

blacklist sdhci-pci
blacklist sdhci
blacklist mmc_core

but the other error message looks even more ominous !
so perhaps you have a deeper issue than the sd card reader

 
paul wheaton
master steward
Posts: 22368
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Likes 3
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Daniel,

On the link you gave, the first answer made me thing "that is way over my head".

But a later answer said to give the "exit" command and it will tell you the problem.   Then use "fsck" on the problem.

So i typed "exit" and pressed enter.  A complaint popped up about "/dev/something5" I can't remember what the "something" really was.

So then i typed " fsck /dev/something5 -y"

A bunch of stuff went by and there some sort of message that said something like "all fixed, have a nice day."

I tried "exit" again and my system started up normally.   I'm back in business!  Have some apples and pie!
 
Daniel Schmidt
Posts: 106
Location: Jacksonville, FL
9
solar tiny house woodworking
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's great to hear! I'm pretty sure the same thing happened to me when I first used Mint Cinnamon over 2 years ago and it went down just as you described. It was just a random fluke and I still use that drive today, and I'm not sure what the caused it, but I haven't ran into it again until seeing this thread. Thanks for the candy!
 
Chris Floyd
Posts: 18
Location: Eastern Shore of Virginia, United States, zone 7b
2
forest garden hugelkultur trees
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Paul,
I am not an expert by any means, but want to pass this on for all us Linux newbies.
Open up a terminal window and copy and paste the following as stated to get your Linux system to do an automated file system check which is not turned-on by default.

1. To force filesystem check for every 30 mounts, run the following command.

sudo tune2fs -c 30 /dev/sda1

2. To force filesystem check for every 3 months, run the following command.

sudo tune2fs -i 3m /dev/sda1

3. To verify that newly added filesystem check conditions are set properly, run the following command.

sudo tune2fs -l /dev/sda1

4. From tune2fs output, you can see not only the filesystem state (clean or not), but also parameters that are related to filesystem checks.
"Maximum mount count" parameter is the number of mounts after which the filesystem check gets triggered.
"Check interval" parameter shows the maximum time between two filesystem checks.
On most Linux distros, these parameters are not set by default, meaning no regular filesystem checks are occurring.

*note* I got this information from a Linux forum, and kept it in a text file.

I put this on every Linux install I do, only I changed mine to every 1 month.
Please note that where it says "/dev/sda1", this is talking about your specific hard drive.
What I am trying to say is that you need to pay attention to exactly what your hard drive is labeled as, and adjust the wording if needed.
I have a desktop with two hard drives installed, one for the wife and one for me.
Hers is labeled sda1, mine is labeled sdb1. So when I copied and pasted the text in terminal for my set-up, I had to change the wording to say sdb1 instead of sda1.
I did the same wording adjustment so I get a file system check every month by substituting a 1 for the 3 in the following command:
sudo tune2fs -i 3m /dev/sda1 (sudo tune2fs -i 1m /dev/sdb1 )
My set-up is in the brackets - hope you understand what I am saying!
Good luck my friend - I absolutely love Linux Mint and find it a great distro for us newbies!
I find Linux much more stable and device-friendly than windows - Linux usually works great on old windows systems.
I have had great fun wiping old XP systems and replacing them with Linux Mint - did this for the grandkids and they love it!
(except my 3 year-old grandson constantly modifies the desktop on his mother and I am constantly having to restore settings for my daughter when she panic-calls me!)
 
And will you succeed? Yes you will indeed! (98 and 3/4 % guaranteed) - Seuss. tiny ad:
Video of all the PDC and ATC (~177 hours) - HD instant view
https://permies.com/wiki/65386/paul-wheaton/digital-market/Video-PDC-ATC-hours-HD
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!