Bookmark Topic Watch Topic
  • New Topic

tinkering with the new software  RSS feed

 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
www2 dot permies.com/forums

please report issues.

everything there will be wiped out later, so feel free to make accounts and lots of silly posts.  test everything!
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
 
brett watson
Posts: 100
Location: Northern California Zone 8b
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
forgive me Paul if you already covered this but do I have to re-register over there?
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
brett watson wrote:
forgive me Paul if you already covered this but do I have to re-register over there?



No.  Although you will need to do the whole "forgot my password" thing.

 
Lolly Knowles
Posts: 159
  • Mark post as helpful
  • send pies
  • Report post to moderator
When I plugged in the address from your first post it took me to a search engine page.  Somehow I don't think that was where I was supposed to be.
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Lolly K wrote:
When I plugged in the address from your first post it took me to a search engine page.  Somehow I don't think that was where I was supposed to be.


Were you able to eventually get to it?
 
Lolly Knowles
Posts: 159
  • Mark post as helpful
  • send pies
  • Report post to moderator
Clicking the first link on the search page took me to the organic lawn care thread, page 5.  Since I'm not terribly sure where I wanted to go (new forum home page?), don't know if I got there. 
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
once in, poke around for a while as a non-logged in user.

Then try to log in with your account and do stuff.

Then log out, create a new account and try to do stuff. 

Please report anything that seems wrong.  If you want to see features added, then we should start a new thread for that.  This thread is for reporting things that are really wrong. 

Cosmetic glitches count.  If nothing else, we can get a list of stuff to work on.  Cosmetic stuff will come after glitchier stuff.

We will probably make the move tomorrow morning.  So the more bugs we find now, the better.

 
Kane Jamison
Posts: 107
Location: West Seattle, WA
3
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hey Paul,

current "Password reset email" looks like this:

From: Moose Saloon  MooseSaloon@javaranch.com

Hi username,

Someone, probably you, made a password recovery request from permaculture forums account.
Please use the following URL to complete the password recovery. You will be sent
to a page asking your email address and the new password.

http://www 2.permies.com/forums/user/recoverPassword/gibberish goes here

Remember: your username is: username


If everyone is going to have to do that, I would consider:

(A) Putting up a message in the forum header and next to the login forms letting everyone know so they don't bounce out of frustration.
and
(B) Load up that automated password email with some promo links! Tell people about the podcast, about your facebook page, about your mailing list, and any other pertinent news updates!
 
joe pacelli
Posts: 91
26
bee forest garden fungi hugelkultur toxin-ectomy trees
  • Mark post as helpful
  • send pies
  • Report post to moderator
Checking in, my master.  I have not re-logged in since last week.  If this message comes through, then I say BRAVO to the mighty and glorious Paul Wheaton! 

Thank you so much!!!
Joe Pacelli
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Kane,  good feedback.  MORE!  So you were able to see the new stuff then?

Joe,  did you see the new stuff?  This forum right now is still running the old software.


 
Dave Bennett
Posts: 686
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
paul wheaton wrote:
No.  Although you will need to do the whole "forgot my password" thing.



I clicked the link in the email and it brought me here logged in and everything just like normal........ so far.
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
paul wheaton wrote:
www2 dot permies.com/forums



If you can figure out the above non-link then you will see the new software.


 
Kane Jamison
Posts: 107
Location: West Seattle, WA
3
  • Mark post as helpful
  • send pies
  • Report post to moderator
http://www 2.permies.com/ isn't loading - it's linked from the breadcrumbs. Also, "Organic Living" etc are linked to /forums/ instead of the subforum itself.

User subnames are loading with Greenhorn etc ranking on the left side of the page.

On the normal installation (www.permies.com) I just got a "You just commented within the last 60 seconds" error. At some point could that be programmed to show if you post more than 2 or 3 or 6 times within 60 secs? I assume it's for spam blocking and not real people blocking?

 
Kane Jamison
Posts: 107
Location: West Seattle, WA
3
  • Mark post as helpful
  • send pies
  • Report post to moderator
I just went to test a Quickreply - which worked but it said posted by Anonymous and I was suddenly logged out. When I went to log back in, I was sent to :

http://www 2.permies.com/forums/jforum

Which gave me a 500 error:

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet execution threw an exception
com.javaranch.jforum.url.JSessionIDFilter.doFilter(JSessionIDFilter.java:32)
com.javaranch.jforum.url.UrlFilter.doChain(UrlFilter.java:66)
com.javaranch.jforum.url.UrlFilter.doFilter(UrlFilter.java:52)
net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
net.jforum.JpaFilter.executeFilter(JpaFilter.java:51)
net.jforum.JpaFilter.doFilter(JpaFilter.java:40)

root cause

java.lang.NoClassDefFoundError: net/jforum/exceptions/ExceptionWriter
net.jforum.JForum.handleException(JForum.java:373)
net.jforum.JForum.service(JForum.java:276)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
com.javaranch.jforum.url.JSessionIDFilter.doFilter(JSessionIDFilter.java:32)
com.javaranch.jforum.url.UrlFilter.doChain(UrlFilter.java:66)
com.javaranch.jforum.url.UrlFilter.doFilter(UrlFilter.java:52)
net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
net.jforum.JpaFilter.executeFilter(JpaFilter.java:51)
net.jforum.JpaFilter.doFilter(JpaFilter.java:40)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs.
Apache Tomcat/6.0.32


NOTE: I was able to log in a moment later
 
Ken Peavey
steward
Posts: 2524
Location: FL
89
  • Mark post as helpful
  • send pies
  • Report post to moderator
[font=Verdana]I hit a glitch, error 500 at 9:27 PM[/font]
I started a new thread in the Singles forum, included a poll with 3 options

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: Servlet execution threw an exception
com.javaranch.jforum.url.JSessionIDFilter.doFilter(JSessionIDFilter.java:32)
com.javaranch.jforum.url.UrlFilter.doChain(UrlFilter.java:66)
com.javaranch.jforum.url.UrlFilter.doFilter(UrlFilter.java:52)
net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
net.jforum.JpaFilter.executeFilter(JpaFilter.java:51)
net.jforum.JpaFilter.doFilter(JpaFilter.java:40)

root cause

java.lang.NoClassDefFoundError: net/jforum/exceptions/ExceptionWriter
net.jforum.JForum.handleException(JForum.java:373)
net.jforum.JForum.service(JForum.java:276)
javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
com.javaranch.jforum.url.JSessionIDFilter.doFilter(JSessionIDFilter.java:32)
com.javaranch.jforum.url.UrlFilter.doChain(UrlFilter.java:66)
com.javaranch.jforum.url.UrlFilter.doFilter(UrlFilter.java:52)
net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59)
net.jforum.JpaFilter.executeFilter(JpaFilter.java:51)
net.jforum.JpaFilter.doFilter(JpaFilter.java:40)

note The full stack trace of the root cause is available in the Apache Tomcat/6.0.32 logs


 
Kane Jamison
Posts: 107
Location: West Seattle, WA
3
  • Mark post as helpful
  • send pies
  • Report post to moderator
There is no New Topic button on  http://www 2.permies.com/forums/f-54/frugality

I do see it on http://www 2.permies.com/forums/f-2/permaculture and Critter Care though
 
Ken Peavey
steward
Posts: 2524
Location: FL
89
  • Mark post as helpful
  • send pies
  • Report post to moderator
having trouble loading the main forum page
http://www 2.permies.com/
getting a blank screen

back button works, but is probably displaying cached page
also able to click on links from the backbuttoned page

Moderation log shows a thread I moved to meaningless drivel, does not show my name as the user.  The next listing of a moved page is also not showing user.
 
Ken Peavey
steward
Posts: 2524
Location: FL
89
  • Mark post as helpful
  • send pies
  • Report post to moderator
This is kinda like last minute christmas shopping
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Andrew just rebooted it with some update stuff.

I think "greenhorn" and the like will be blank to start.
 
Charles Kelm
Posts: 171
Location: Western Washington (Zone 7B - temperate maritime)
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
Just testing.  Don't mind me.
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
If you see "Powered by SMF 1.0.8" at the bottom then you are using the old software (currently in production). 

If you see "Powered by JForum" at the bottom then you are tinkering with the new software (not yet in production).


 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Ken Peavey wrote:
having trouble loading the main forum page
http://www 2.permies.com/
getting a blank screen



Working on it. 

If you add "index.html" you get a little closer.

We will probably need to test the wiki stuff over there too.

 
Dave Bennett
Posts: 686
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
I did the lost password thingie but no email showed up to reset my password so I can't log in.
 
Ken Peavey
steward
Posts: 2524
Location: FL
89
  • Mark post as helpful
  • send pies
  • Report post to moderator
worked with index.html added
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Dave Bennett wrote:
I did the lost password thingie but no email showed up to reset my password so I can't log in.


Andrew bounced it again.  Try it now.
 
Jason Houx
Posts: 7
Location: Lima, Ohio
  • Mark post as helpful
  • send pies
  • Report post to moderator
paul wheaton wrote:
Andrew bounced it again.  Try it now.



www2.permies.com/index.html does work but doesn't if you leave off the "index.html".  poking around the links seem to point back to the non-www2 location....  is that expected behavior?
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
Jason Houx wrote:

www2.permies.com/index.html does work but doesn't if you leave off the "index.html".  poking around the links seem to point back to the non-www2 location....  is that expected behavior?


Both issues being worked on.
 
Ken Peavey
steward
Posts: 2524
Location: FL
89
  • Mark post as helpful
  • send pies
  • Report post to moderator
I think its just one line in the output preparation code.  Should be a simple fix when these guys find time.
 
Jorja Hernandez
Posts: 78
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
Bring out your dead .... Bring out your dead ...

OK, so far so good.
 
gani et se
Posts: 215
Location: Douglas County OR
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
Hey Paul,
Can I report issues on the new tinkering forum, or should I just post them here?
 
gani et se
Posts: 215
Location: Douglas County OR
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
just tried to post anything -- new topic and reply to a topic -- without logging in not possible. I know this may be by intention, but it's different than yesterday when I logged in, but then my post was anonymous. (I can touch the post buttons when logged in.)
 
paul wheaton
master steward
Posts: 22598
Location: missoula, montana (zone 4)
bee chicken hugelkultur trees wofati woodworking
  • Mark post as helpful
  • send pies
  • Report post to moderator
post stuff here.

yes, the anonymous post stuff was turned off.
 
gani et se
Posts: 215
Location: Douglas County OR
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
the header where it says "permaculture forums >> organic and sustainable" (etc.) gets pretty clunky. if I click on the permaculture forums section of that I get bounced out. If I click on the organic and sustainable portion, I go back to the forums front page. when I am in the cooking/food preservation the line breaks at my resolution and screen size. Perhaps the organic and sustainable should be elsewhere as a description but not as a link? or something. Oh. I see Brice mentions that in a post on the new forum.
Mentioned in a post to the new forum some of the changes that I liked. I'll go look again and post here when I remind myself.
[edit]
just went back to try that, but have been logged out. assuming that's a timing out thing, or because I didn't check log me in each time? I am keeping a tab of the other site open at the moment, so not a browser restart issue.
[/edit]
 
gani et se
Posts: 215
Location: Douglas County OR
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
Comments about the composing window:
Some help page for a couple buttons/dropdowns may be needed if kept -- javadoc, language list.
I like the simplicity of the formatting options. Poll looks like it could be a fun addition! But I personally might need an explanation of what a poll option might be...
 
                              
Posts: 1
  • Mark post as helpful
  • send pies
  • Report post to moderator
Does this have the chat like the one that was on squattheplanet forum? I am wondering if anyone is working on NPTECH ethics education to eliminate organized crime by autodesk inventor software with infrastructure of vocabulary throughput topography tools for ethics education and ISO14000 measurement tools of real time web infrastructure? HTML5 will be part of this. 
 
Raven Sutherland
Posts: 164
Location: MAINE
  • Mark post as helpful
  • send pies
  • Report post to moderator
i guess i'm in...but then again it's not even 5 am yet

i did smush a big nasty black spider in the bathroom tho.
 
dave brenneman
Posts: 38
Location: london, england
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
hmm, i just tried  permies/index dot html and got this:

The supplied data is invalid. Please double check you entered your E-MAIL and not your username in the first field.


thought that could be operator error, but i double checked to make sure i was entering the right email and got it again. I'll try a couple more times and see what happens...
 
dave brenneman
Posts: 38
Location: london, england
1
  • Mark post as helpful
  • send pies
  • Report post to moderator
not getting that error message any more.
 
brevity is the soul of wit - shakepeare. Tiny ad:
Complete Wild Edibles Package by Sergei Boutenko (1 HD video + 10 eBooks)
https://permies.com/t/70674/digital-market/digital-market/Complete-Wild-Edibles-Package-Sergei
    Bookmark Topic Watch Topic
  • New Topic
Boost this thread!